How can we brighten your day?

Follow

What Android devices are supported?

Requires devices with Bluetooth 4.0/Bluetooth Smart running Android 5.0+

 

  • Samsung Galaxy S3, S4, and S5
  • Samsung Galaxy Note II and III
  • Google Nexus 4, 5, and 7-2nd Gen only
  • Other Android devices may be compatible - please check the Google Play to verify your device is compatible with the ilumi app. If you're using an unsupported device, it's possible that the app will not display in the search results or you will receive a message that your device is unsupported.

Download the free ilumi app on iOS iTunes

 

ilumi may work with devices on Android OS 4.3 or higher, but as Google releases new versions of Android, ilumi will be unable to continue to support older versions of Android. 

Periodically, Google may make changes in the Android operating system that affect Bluetooth connectivity, negatively or positively, so please reach out to support@ilumi.co if you are experiencing Bluetooth connectivity issues. 

We highly recommend keeping your device updated to the latest possible iOS & Android OS for the best possible results.

Please note: As technology changes, we will make every effort to remain backwards compatible for as long as we can. As changes are made to your device's operating system, sometimes important and necessary changes are made that prevents ilumi from working at an optimal level on earlier versions. After careful review and testing, we may make the decision to change our minimum supported requirements. Please reach out to support@ilumi.co if you have any questions!

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request